Blank Screen after last update


#1

Hi Guys

I just update my Piwik to latest release and I have blank screen. I can not login. I did small investigation and I can see some errors

GET http://85.17.23.18/piwik/plugins/Morpheus/images/logo.svg 404 (Not Found) (index):60
GET http://klanmichalakow.org/piwik/angular.min.js.map 404 (Not Found) (index):24
Uncaught TypeError: Cannot read property ‘invoke’ of undefined index.php?module=Proxy&action=getCoreJs&cb=b793e7d3f1ed85a0dcef9e7bd86fed9f:1146
GET http://85.17.23.18/piwik/plugins/Morpheus/images/logo.svg 404 (Not Found)

I did not update piwik about one year, I do not remember what version I had before upgrade, sorry :slight_smile:
I think I did update to 2.8.3

regards
Karol


(Matthieu Aubry) #2

Can you check in your server error log ? you will find there an error message, which likely you can find in FAQ: FAQ Archive - Analytics Platform - Matomo


#3

Hi Matt

Thank you for that. Could you please tell my where is server error logs?

Regards
Karol


#4

This is my error log:

[Thu Oct 23 04:31:21 2014] [error] [client 195.212.29.77] File does not exist: /home/kczarnec/domains/klanmichalakow.org/public_html/piwik/angular.min.js.map, referer: http://klanmichalakow.org/piwik/
[Thu Oct 23 04:31:21 2014] [error] [client 195.212.29.77] File does not exist: /home/kczarnec/domains/klanmichalakow.org/public_html/404.shtml, referer: http://klanmichalakow.org/piwik/
[Thu Oct 23 04:31:23 2014] [error] [client 195.212.29.77] File does not exist: /home/kczarnec/domains/klanmichalakow.org/public_html/piwik/angular.min.js.map, referer: http://klanmichalakow.org/piwik/
[Thu Oct 23 04:31:23 2014] [error] [client 195.212.29.77] File does not exist: /home/kczarnec/domains/klanmichalakow.org/public_html/404.shtml, referer: http://klanmichalakow.org/piwik/

I have also this warrning:

[Thu Oct 23 12:53:04 2014] [warn] [client 157.55.39.139] mod_fcgid: stderr: 30719


#5

I have the same problem after the latest update, but there are no errors in my PHP error log.

HTTP headers are fine, but there is no page content sent to the browser.


#6

I solved my problem by deleting file in the piwik directory except the config folder.

I didn’t lose any data or have to reconfigure anything, happily, and stats were still being collected while the dashboard was dead.