Blank Page After Piwik Upload


#1

Hello,

I’ve just uploaded Piwik to my web server (Windows, Zend Server, PHP 5.3.2), and tried to navigate to the appropriate url to begin installation. However all it does is spin for about half a minute, and then fails, showing just a blank page. Nothing shows in the php logs either so I’m at a loss as to why this is happening. I’ve checked, and there are no .htaccess files anywhere on the server (as suggested in other posts).

Any help is greatly appreciated.
-Tim.


#2

I have also increased the memory_limit directive to 320M, as suggested in other threads. This produces a 500 server error, but still no php logs.


(Matthieu Aubry) #3

Check in the server error log file for the error?

and/or check that error logging is enabled in your php.ini configuration


#4

Any way you can upgrade teh php version? even up to 5.3.8 or something thereabouts… 5.4.x would be ideal though.

good luck


#5

matt,
Which server error log file are you referring to, and where would I find that?
PHP error logging is enabled (error_log has a path, and error_reporting is set to E_ALL), and the php log file is showing notices/errors from other scripts on my site, but none that relate to Piwik.

lesjokolat,
Upgrading php is going to take a while to test and debug as we have some pretty old scripts on our site that I don’t want to break. I’d like to update eventually, but for time’s sake I need to avoid that if possible.


(Matthieu Aubry) #6

Can you try setup: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

Maybe this will solve the issue after you run the console core:archive command once?


#7

I ran the following command:


"C:\Path\To\Php\php.exe" "C:\Path\To\Piwik\console" core:archive --url=http://intranet-url/

which returned:


The configuration file {C:\Path\To\Piwik/config/config.ini.php} has
 not been found or could not be read.




  [InvalidArgumentException]
  There are no commands defined in the "core" namespace.


(Matthieu Aubry) #8

make sure the folder (and files within) are readable and writable: these two folders:

config/

tmp/


#9

They are. In fact I’ve made the entire Piwik folder readable/writeable just for good measure. Still won’t work.


(Matthieu Aubry) #10

Sorry I don’t know how to help further, I thought giving read/write access to folders (and files within) would have worked


#11

You didnt happen to have earlier any sort or rewrite rules did you? Also when it comes to permissions did you ensure the actual user windows ID or group was specified on teh folders?


#12

No, no rewrite rules. And my account has “Full Control” permissions on the folder and everything in it.