Basic analytics numbers completely wrong


(larryjackholmes2) #1

Hi,

Our account for libertyhumanrights.org.uk is producing very unreliable visitor numbers, pageviews etc.

EG:
Date range 1.1.18 - 30.6.18 = 11,048 visitors
Date range 1.2.18 - 27.2.18 = 14,364 visitors
One blog on 11.2.18 = 25,000+ visits

I assume this is a bug?

Thanks.


(Peterbo) #2

Well you can imagine that nobody would use Matomo, if the numbers were regularly off like this.

What exact range settings did you use to get the stats (date range, or “month”) - did archiving return errors at some point, did you get timeouts when requesting stats for a long date range, did you segment your results, etc.


(larryjackholmes2) #3

Hi Peterbo.

I was using date range.

I just ran a random date range of 1 Feb 2018 - 30 April 2018

You can see the visits overview graph with visitor numbers. The Visits Summary has no visits.

If I run a “month” (in this case May 2018) I’m told we’ve had no visits since March 2017.

I do get time outs if I run long date ranges. but not always.

I get similar inconsistencies when running a segment.

It may well be how our accoutnis configured. Any help you can offer to rectify would be hugely appreciated.

Thanks.


(larryjackholmes2) #4

Here’s the no visits since March 2017 “May 2018” result:


(Fabian Dellwing) #5

This looks a lot like something is wrong with the archiving. @peterbo can probably say more about this.


(Peterbo) #6

PLease use the cron archiving for your instance: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

This will reliably crunch your numbers.


(Austin Clamon) #7

I am having this same issue suddenly even though I have been using chron archiving for several months. I can view a site that has obviously gotten traffic and it will say zero visits. There are some errors in my chron log. I will attach it. Any help would be much appreciated.

piwik-archive-output.log


(Fabian Dellwing) #8

So, nothing gets archived because of errors:

INFO [2018-07-09 18:00:48] 6601  Skipped 32 websites
INFO [2018-07-09 18:00:48] 6601  - 0 skipped because no new visit since the last script execution
INFO [2018-07-09 18:00:48] 6601  - 0 skipped because existing daily reports are less than 3600 seconds old
INFO [2018-07-09 18:00:48] 6601  - 0 skipped because existing week/month/year periods reports are less than 3600 seconds old
INFO [2018-07-09 18:00:48] 6601  - 32 skipped because got an error while querying reporting API

The error speaks for itself, you are trying to load the phar.so 2 times. See PHP Warning: Module 'modulename' already loaded in Unknown on line 0 for tips.


(Pat Hadley) #9

Hi, I’m one of the developers for libertyhumanrights.org.uk and work with @larryjackholmes2 . I’ve checked the site and that archiving script is running on cron according to the steps above. We found that it may have stopped for a few weeks due to an issue with provisioning but is now restored.
However, we still have identical problems to the above. Including for historic periods going back to 2017.
How is it that the graphs and sparklines appear to show credible data but the counts are 0?
Exporting the data as a csv seems to give detailed data which reflects the graphs. So, the data is there but there’s a problem displaying!?
Any help appreciated. Thanks.


(Fabian Dellwing) #10

Please show a current logfile of the archiving process.


(Pat Hadley) #11

Hi @fdellwing
Apologies for the long delay.

We looked at the logs immediately and found even stranger things:

INFO CoreConsole[2015-07-10 09:00:25] ---------------------------

-------------------------------------------------------
Using this 'archive.php' script is no longer recommended.
Please use '/path/to/php /var/www/sites/liberty/analytics/piwik/console core:archive --url=www.liberty-human-rights.org.uk/analytics/piwik/' instead.
To get help use '/path/to/php /var/www/sites/liberty/analytics/piwik/console core:archive --help'
See also: http://piwik.org/docs/setup-auto-archiving/

If you cannot use the console because it requires CLI
try 'php archive.php --url=http://your.piwik/path'

The last time the archive reports running correctly is 2015 but the problems don’t start till 2017.

We’re now downloading a db dump and looking at that - is there anything to look out for?

Thanks