Automatisches Update funktioniert nicht


#1

Hallo

ich nutze die Version 1.0 von Piwik. Da ich kein Held von htm, php & Co bin, ließ ich mir die Software gebührenpflichtig aufspielen.

Vom ersten Update an funktionierte das automatische Update nicht.

Fehlermeldung:

Fatal error: Class ‘ZIPARCHIVE’ not found in /kunden/1xxxxx_xxxxx/webseiten/shop/piwik/core/Unzip.php on line 28

Offenbar taucht der Fehler nicht oft auf, hab hier nichts Erhellendes drüber gefunden.

Der Shop liegt bei domainfactory

Hat jemand 'ne Idee woran’s liegt?


(Eukaryota) #2

Hallo bsb,

überprüfe mal, ob du noch genügend Speicherplatz auf deinem Server hast.

Bei mir kam etwas Ähnliches, weil ich vorher meinen beschränkten Providerplatz mit Wordpress-Installation zugeballert habe. Da war einfach kein Platz mehr für entpackte Piwik-Files.

Viele Grüße


#3

Hallo Eukaryota,

ne, daran dürfte es nicht liegen, sind noch 10GB frei

trotzdem Danke für deine schnelle Antwort


#4

Im englischen Forum hatte ich den Hinweis gefunden, daß die Dateiattribute auf 777 gesetzt werden müssen. Hab ich damals gemacht - weiß nur nicht mehr welche Dateien das waren, ist 6 Wochen her… Hatte nichts gebracht.


#5

Hört sich für mich eher an als wurde deine PHP-Umgebung nicht mit zip- / zlib-Unterstützung kompiliert bzw. als wurde die entsprechende zip-Extension für PHP < 5.2 nicht eingebunden. Frag mal bei deinem Provider nach oder schau dir die phpinfo-Ausgabe an.


#6

@ n0V1

Danke für den Hinweis . Hatte 'ne ältere php-Version laufen. Mit php 5.2.13 lief das Update jetzt problemlos.

Herzlichen Dank und Grüße