Automatic upgrade error from 1.2 to 1.2.1


#1

The following error appears on all my Piwik installations when using the automatic upgrade function. After that, all installations seem to work normal.


There is an error. Please report the message and full backtrace in the Piwik forums.

Notice: Undefined property: Piwik_CoreUpdater_Controller::$pathRootExtractedPiwik in /srv/www/piwik/plugins/CoreUpdater/Controller.php on line 99 

Backtrace -->
#0 Piwik_ErrorHandler(8, Undefined property: Piwik_CoreUpdater_Controller::$pathRootExtractedPiwik, /srv/www/piwik/plugins/CoreUpdater/Controller.php, 99, Array ()) called at [/srv/www/piwik/plugins/CoreUpdater/Controller.php:99]#1 Piwik_CoreUpdater_Controller->oneClick_Unpack() called at [/srv/www/piwik/plugins/CoreUpdater/Controller.php:63]#2 Piwik_CoreUpdater_Controller->oneClickUpdate()#3 call_user_func_array(Array ([0] => Piwik_CoreUpdater_Controller Object ([] => ,[] => Array (),[] => Array (),[] => Array (),[] => CoreUpdater,[] => ,[] => ,[] => 0,[] => Piwik_Site Object ([] => 0),[newVersion] => 1.2.1,[pathPiwikZip] => /srv/www/piwik/tmp/latest/latest.zip),[1] => oneClickUpdate), Array ()) called at [/srv/www/piwik/core/FrontController.php:125]#4 Piwik_FrontController->dispatch() called at [/srv/www/piwik/index.php:57]


#2

Hi

I have had the same error during automatic upgrade from 1.2 to 1.2.1


(Peterbo) #3

This Bug is fixed with 1.2.1. The update was successful, this is only an error message with no essential function.