Automatic Update not working correctly


(Dominik) #1

Hi,
I tried to update two Matomo installations from 3.6.0 to 3.6.1 by automatic update. The updater tells me, that the update was successful, but I still get the update notification in backend. What went wrong?
There are many files on the webspace changed the time I did the update, so I assume that the file download and extraction was done, but there was no database upgrade screen during the update. Is that the missing part?
Regards,
Dominik


#2

Same here!

matomo361


(Fabian Dellwing) #3

Try reloading without cache, I have this problem with every update.


(Dominik) #4

Cleared OPcache and tried another browser without any difference. It is the first time on the same system that behaves this way, so I don’t think it is a cache problem here…


#5

https://builds.matomo.org/piwik.zip?cb=3.6.1

it is only 3.6.0


#6

Same issue here.

I am still in 3.6.0 after the automatic upgrade.

I don’t think it’s an issue with the browser or OPCACHE because if we check the file CHANGELOG.md it the one of the 3.6.0.

Edit : Now seems to be fixed


(Dominik) #7

Yes, seems to be fixed. The update is now complete and shows version 3.6.1.


(Lukas Winkler) #8

Hi,

sorry for the confusion. It took a while for the update to be uploaded after the publishing due to slow internet.

Everything should be fine now.


(Yorh Ekin) #9

I see a white browser page. Puuuuuhhh …

After hitting the reload browser button I see and read this …

An error occurred

Your Matomo version 3.6.1 is up to date.

:rofl:

https://matomo.org/changelog/matomo-3-6-1/

Database upgrade

This release does not contain any major database upgrade.

The BACK button works great
:rofl:

Goto Matomo is my Dashboard … and I thought it was a link to their site.
:rofl:

No “major” Database upgrade.
:rofl:

Never thought that PHP and Security without Shell access could be so funny.
:rofl:


(Fabian Dellwing) #10

So, what exactly is your problem (besides you write hard to read posts)?


(Lukas Winkler) #11

A post was split to a new topic: The class Marketplace couldn’t be found