Automatic Emailing of Reports - Labels broken

When manual firing off an email report the Subject line of the email comes in as “Web Analytics Reports” Hello, Please find in attached file your Date range report for.

When the automatic delivery fires off at 1:00am, all reports come in as “CoreHome_WebAnalyticsReports” General_Report Sitename - CoreHome_DateFormat - PDFReports_EmailHello PDFReports_PleaseFindAttachedFile

This only started occuring since upgrading to 1.9.

Any ideas on how to fix? Appreciate it.

Can you re-upload all files in piwik/langs/ directory ?

If that does not fix it, let me know, that’s surprising bug

No dice, replaced the lang directory and same thing, even shows as “CoreHome” in the actual PDFs that are generated. This only happens with automatic nightly reports, not if manually kicked off…

That is VERY strange. Can you check your config/config.ini.php is correct and does not contain language overwrite option?

Nope no re-write option, file was just modified on the 18th when I did the upgrade.

Sorry at this stage I dont know, as it’s the first time we hear. If you want Piwik expert to fix it for you for a fee, contact us at:

I have the same error with my installation, it generates the daily reports without the text sippets. Weekly or monthly reports did not work.
When i look in my webserver logfiles, i found an php error that the script was cancel because the maximum execution time was exceeded.
I fix the error by increase the maximum execution time in my php.ini to 60 Seconds and the reports work again.

I check an other installation wich i did not upgrade yet an it works with an maximum execution time of 30 seconds, after upgrade i could reproduce the error an fix it by increase the maximum execution time.

So i think you should look in your webserver logfile for error or increase the maximum execution time.

Good luck Marc

Same here. E-Mail report is broken since the update was applied. Increasing execution time did not help. The visitor chart is broken as well. (see png)

Confirming exact same results here. After increasing time out

One more confirmation and it’s a shame because it’s the first time reports were actually sent (was broken forever).

It’s the PDFReports.php, anyone have the old version? from 1.8.4? That one worked?

I see it’s in as a bug fix…

I have committed a bug fix at:

To apply and test the bug fix, you just need to delete the code in red here:

and also add this line in green here: (bottom of page)

Then the reports should work again. please confirm if you still have a problem after! Thanks!

Matt, thanks for the fix, I think I replaced the code changes correctly, we’ll find out tonight. Any way you could post the updated translate.php and piwik.php files here so I know I did it right? Appeciate your help.

We are releasing bug fix version within 48 hours


Just FYI- after replacing the code I had the same results. If you could post the file I’d appreciate it, as I have a bunch of emails that go out to folks and will again tonight where they contact me back and go… “Who the heck is CoreHome”? Appreciate it…

please update to 1.9.1 where this bug has been fixed! Changelog Archive - Analytics Platform - Matomo

Thanks Matt, appreciate the quick turn around and hard work…