"Authorization Required" for "Do not track" preference (opt out)


(Marbot) #1

Hi, I included a opt out with an iframe on my site. After the last update to 1.8.2 I get Authorization errors for this feature. Does anybody happen to know what to do to allow access to the iframe? (The tracking still works since I allowed the access to the tracking files.)


(Matthieu Aubry) #2

Unfortunately it seems with Safari a bug: Make Piwik opt-out feature work on safari and internet explorer · Issue #3135 · matomo-org/matomo · GitHub


(Marbot) #3

Thank you for your reply. The only problem for me is that I use Firefox. I have tested Chrome too, which is showing the same behaviour. Additionally the piwik installation is running on the same domain as well as the server.

Are there specific solutions for these two browsers already in place which I did not find in the instructions?

However, it seems to me that the new versions of the two browsers may also be the cause the problem. I did not check directly after upgrade of Piwik, so I may well be wrong with my first diagnosis.