Aucune visite autre que celles de mon réseau interne ne sont comptabilisées


#1

Bonjour,
Je rencontre un problème avec piwik, ceci suite à priori à une mise à jour mais ce n’est pas certain.
Aucune visite autre que celles de mon réseau interne ne sont comptabilisées, alors que j’ai des visiteurs qui viennent de l’extérieur.
Auriez vous rencontré le même problème ou sauriez vous comment le résoudre?

Cordialement


#2

Bonjour,

J’ai le même soucis l’avez vous résolu ?

Merci


(Matthieu Aubry) #3

Verifiez que le script Javascript dans vos pages contient l’URL vers Piwik qui est une URL publique et non intranet ?


#4

Oui, c’est bien le cas.

J’ai installé la version 2.9.1 ce matin et je vais vérifier si ça remarche.

Est il possible de recalculer les rapports d’un jour précis cas, je suis sûr d’avoir eu des accés ?

Merci


#5

Bonjour,
Oui mon problème subsiste toujours, je n’ai pas de solution pour l’instant hélas. Le script Javascript dans nos pages contient l’URL vers Piwik qui est une URL publique. A noter que cela fonctionner avec des versions ultérieures auparavant.

La version 2.9.1 a t’elle résolu le problème?


#6

Bonjour

Oui pour moi avev la 2.9.1, le calcul semble refonctionner par contre, j’ai le problème de relancer le calcul des jours manquants ?

Si possible.


#7

J’ai mis à jour avec la dernière version 2.9.1 et mon problème reste le même


#8

As tu changé le délai de recalcul dans les paramètres, j’ai positionné à 300 secondes… Et depuis, il me semble que ça marche ?
Un des problèmes que j’ai eu en même a été le passage en HTTPS ? Est ce que Piwik et ton site sont sur ce protocole ? Et dans ce cas, est ce que Piwik ne génére pas de message auprès des internautes bloquants ?


#9

C’est pareil. Mon serveur piwik est en https et tous les sites web situés sur d’autres serveurs ne le sont pas, cela n’a pas posé de problème à priori jusqu’alors. Aucun message d’erreur.

Par contre j’aimerais bien savoir dans quelle table mysql de piwik sont stockées les IPs, cela me permettrait de vérifier si aux moins ils les a en base.
Au sinon j’ai regardé au niveaux des exclusions ips bien sur et rien.
Je ne comprends vraiment pas.


#10

Si vous souhaitez, je peux tester l’accès de mon poste à votre site en MP ? pour être sûr que bien accessible de l’extérieur ?


#11

C’est ok, il y avait bien un soucis niveau réseau et mon serveur n’était pas accessible de l’extérieur.