Archiving doesn't work :-(


(svenabels) #1

Hi,

I’m using Piwik 0.2.37 on an ubuntu system and it runs fine. However, I never get any updates in Piwik but I can see that new data is stored in the database. even when I run the archiving.sh script manually it doesn’t update the website and the archive tables in the database. However, I can see the XML output in the shell.

So what I do at the moment is that I drop all archive_* tables and then I run the archive.sh script. This recreates all archive tables and works fine. However, this is of course taking a lot of time and not a good solution.

In the global.ini.php I have tried setting enable_browser_archiving_triggering to both 0 and 1 but it doesn’t make any differences. What works fine is if I set always_archive_data_day to 1 but I understood from the documentation that this is not recommended and should not be used on a long term.

Does anyone have an idea?

Best greetings,

Sven


(svenabels) #2

Hi,

does noone have an idea for this?

Am I the only one with this problem?

Best greetings,

Sven


(vipsoft) #3

You might have to up your memory limit. See php.ini.

Typically the CLI version is configured to run with no limit.


(dominikh) #4

Same here.
When I don’t delete the tables by hand (or use set always_archive_data_day=1), the displayed reports won’t be updated.

If I delete them though, I don’t have to run the shell script, a simple reload of the website generates the report.

There is no indication of the memory limit being exceeded in any logs.

Do I even understand the system correctly, that, according to the default config, the reports are supposed to be regenerated every 10 seconds?