Archiving doesn't work


(trefle) #1

Hi,

i have tried to enable auto archiving as it’s explains here : piwik.org/docs/setup-auto-archiving/

but i have a problem when i tried to do sh archive.sh i have this error message :

Piwik # open source web analytics
 
 The mysql driver is not currently installed
 Backtrace:
 
 #0 /var/www/html/fr/piwik/libs/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
 #1 /var/www/html/fr/piwik/core/Db/Pdo/Mysql.php(30): Zend_Db_Adapter_Pdo_Mysql->_connect()
 #2 /var/www/html/fr/piwik/core/Piwik.php(1479): Piwik_Db_Pdo_Mysql->getConnection()
 #3 /var/www/html/fr/piwik/core/FrontController.php(218): Piwik::createDatabaseObject()
 #4 /var/www/html/fr/piwik/index.php(103): Piwik_FrontController->init()
 #5 {main}
 
     * Piwik homepage
     * Piwik Frequently Asked Questions
     * Piwik Documentation
     * Piwik Forums
     * Piwik Online Demo

php info give me that :

mysql
 MySQL Support    enabled
 Active Persistent Links     0
 Active Links     0
 Client API version     5.0.77
 MYSQL_MODULE_TYPE     external
 MYSQL_SOCKET     /var/lib/mysql/mysql.sock
 MYSQL_INCLUDE     -I/usr/include/mysql
 MYSQL_LIBS     -L/usr/lib/mysql -lmysqlclient
 
 Directive    Local Value    Master Value
 mysql.allow_persistent    On    On
 mysql.connect_timeout    25    25
 mysql.default_host    no value    no value
 mysql.default_password    no value    no value
 mysql.default_port    no value    no value
 mysql.default_socket    no value    no value
 mysql.default_user    no value    no value
 mysql.max_links    Unlimited    Unlimited
 mysql.max_persistent    Unlimited    Unlimited
 mysql.trace_mode    Off    Off
 
 mysqli
 MysqlI Support    enabled
 Client API library version     5.0.77
 Client API header version     5.0.77
 MYSQLI_SOCKET     /var/lib/mysql/mysql.sock
 
 Directive    Local Value    Master Value
 mysqli.default_host    no value    no value
 mysqli.default_port    3306    3306
 mysqli.default_pw    no value    no value
 mysqli.default_socket    no value    no value
 mysqli.default_user    no value    no value
 mysqli.max_links    Unlimited    Unlimited
 mysqli.reconnect    Off    Off
 
 PDO
 PDO support    enabled
 PDO drivers     mysql, sqlite
 
 pdo_mysql
 PDO Driver for MySQL, client library version    5.0.77

I think pdo mysql are enabled so i don’t know why it’s doesn’t work cuold you help me ?

Thxs,

sorry for my english.

ps : I have piwik 0.5.4


(derSpinner) #2

There is the same problem.
How do you choose it?

Имеется та же проблема.
Как Вы решили её?


(vipsoft) #3

Try running:

ldd /usr/local/zend/lib/php_extensions/pdo.so
ldd /usr/local/zend/lib/php_extensions/pdo_mysql.so
ldd /usr/local/zend/lib/php_extensions/mysqli.so

This will tell you if there’s a shared library dependency preventing these php extensions from loading. (Unfortunately, any “not found” errors are platform-specific. Use ldconfig or soft-links, as appropriate for your OS.)


(derSpinner) #4

[quote=vipsoft @ Mar 9 2010, 02:26 PM]# ldd /usr/local/zend/lib/php_extensions/pdo_mysql.so
libmysqlclient.so.16 => not found
libz.so.1 => /usr/lib64/libz.so.1 (0x00002af2d3335000)
libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002af2d3549000)
libnsl.so.1 => /lib64/libnsl.so.1 (0x00002af2d3782000)
libm.so.6 => /lib64/libm.so.6 (0x00002af2d399a000)
libc.so.6 => /lib64/libc.so.6 (0x00002af2d3c1d000)
/lib64/ld-linux-x86-64.so.2 (0x00000038c8e00000)

ldd /usr/local/zend/lib/php_extensions/pdo.so

    libc.so.6 => /lib64/libc.so.6 (0x00002b5b1b82e000)
    /lib64/ld-linux-x86-64.so.2 (0x00000038c8e00000)

ldd /usr/local/zend/lib/php_extensions/mysqli.so

    libmysqlclient.so.16 => not found
    libz.so.1 => /usr/lib64/libz.so.1 (0x00002af038f27000)
    libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002af03913b000)
    libnsl.so.1 => /lib64/libnsl.so.1 (0x00002af039374000)
    libm.so.6 => /lib64/libm.so.6 (0x00002af03958c000)
    libc.so.6 => /lib64/libc.so.6 (0x00002af03980f000)
    /lib64/ld-linux-x86-64.so.2 (0x00000038c8e00000)[/quote]

The reason for this absence: libmysqlclient.so.16?


(vipsoft) #5

Precisely.

Again, use ldconfig (if available) or soft-links (if all else fails), so Zend Server php-cli can find the missing library.


(derSpinner) #6

Works. Thank you.