Archive.php throws notice in 1.9.1

Recently upgraded to Piwik 1.9.1 from 1.8.4 and while running the archive command from the terminal (php misc/cron/archive.php – url=http://piwik.example.com)

…then it looks like this:

[2012-11-02 21:28:01] [e80480df] NOTE: if you execute this script at least once per hour (or more often) in a crontab, you may disable ‘Browser trigger archiving’ in Piwik UI > Settings > General Settings.
[2012-11-02 21:28:01] [e80480df] see doc at: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo
[2012-11-02 21:28:01] [e80480df] ---------------------------
[2012-11-02 21:28:01] [e80480df] INIT
[2012-11-02 21:28:01] [e80480df] Querying Piwik API at: http://piwik.example.com/index.php
[2012-11-02 21:28:01] [e80480df] Running as Super User: admin
[2012-11-02 21:28:01] [e80480df] Notes
[2012-11-02 21:28:01] [e80480df] - Reports for today will be processed at most every 3600 seconds. You can change this value in Piwik UI > Settings > General Settings.
[2012-11-02 21:28:01] [e80480df] - Reports for the current week/month/year will be refreshed at most every 3600 seconds.
[2012-11-02 21:28:01] [e80480df] - Archiving was last executed without error 3 hours 45 min ago
[2012-11-02 21:28:01] [e80480df] Will process 13 websites with new visits since 3 hours 45 min , IDs: 23, 30, 32, 39, 42, 46, 63, 68, 71, 72, 73, 77, 93
[2012-11-02 21:28:01] [e80480df] ---------------------------
[2012-11-02 21:28:01] [e80480df] START
[2012-11-02 21:28:01] [e80480df] Starting Piwik reports archiving…
[2012-11-02 21:28:02] [e80480df] Archived website id = 23, period = day, Time elapsed: 0.452s
[2012-11-02 21:28:05] [e80480df] Archived website id = 23, period = week, 1357 visits, Time elapsed: 3.689s
[2012-11-02 21:28:15] [e80480df] Archived website id = 23, period = month, 3852 visits, Time elapsed: 10.158s
PHP Notice: unserialize(): Error at offset 0 of 183 bytes in /data/www/misc/cron/archive.php on line 440

nter>nginx/1.1.19/h1>d>erializing the following response: [2012-11-02 21:29:16] [e80480df] Archived website id = 23, period = year, 0 visits, Time elapsed: 60.104s [2012-11-02 21:29:16] [e80480df] Archived website id = 23, today = 89 visits, 4 API requests, Time elapsed: 74.405s [1/13 done] [2012-11-02 21:29:17] [e80480df] Archived website id = 30, period = day, Time elapsed: 1.152s [2012-11-02 21:29:28] [e80480df] Archived website id = 30, period = week, 1737 visits, Time elapsed: 10.824s [2012-11-02 21:29:54] [e80480df] Archived website id = 30, period = month, 4872 visits, Time elapsed: 26.160s PHP Notice: unserialize(): Error at offset 0 of 183 bytes in /data/www/misc/cron/archive.php on line 440 nter>nginx/1.1.19/h1>d>erializing the following response: [2012-11-02 21:30:54] [e80480df] Archived website id = 30, period = year, 0 visits, Time elapsed: 60.062s [2012-11-02 21:30:54] [e80480df] Archived website id = 30, today = 72 visits, 4 API requests, Time elapsed: 98.200s [2/13 done] [2012-11-02 21:30:54] [e80480df] Archived website id = 32, period = day, Time elapsed: 0.512s [2012-11-02 21:30:58] [e80480df] Archived website id = 32, period = week, 513 visits, Time elapsed: 4.191s [2012-11-02 21:31:10] [e80480df] Archived website id = 32, period = month, 965 visits, Time elapsed: 11.594s PHP Notice: unserialize(): Error at offset 0 of 183 bytes in /data/www/misc/cron/archive.php on line 440 nter>nginx/1.1.19/h1>d>erializing the following response:

did you

Disable browser triggers for Piwik archiving and limit Piwik reports to updating every hour

see link

http://piwik.org/setup-auto-archiving/

It is disabled.

I noticed in the error lines there is reference to ngix 1.1.8. There are several versions newer. Is there any way to check on your systems distro for the version you re running and if there is a newer version you can apply it?

It is not running 1.1.8, it is running version 1.1.19 and has been working fine for over a year on the server, this appeared since updating Piwik a few days ago. Nothing else was updated or modified at that time.

ok well maybe this is a bug in piwik whereby the ngix v 1.19 compatibility was messed up in the newer version. I will check to see if i have a ngix version on my 1.9.1 install.

it looks like a rare case of data errors. I recommend to try deleting the data for this day and re-process it: How to - Analytics Platform - Matomo