Archive.php never completes due to server error

I’ve uploaded millions of log lines into my database, and when I try to run archive.php I get this error:

memory_limit = 5G
[2013-05-23 16:27:08] [34aaee9a] ERROR: memory_used = 4065864 The response was empty. This usually means a server error.
 This solution to this error is generally to increase the value of 'memory_limit' in your php.ini file. Please check you
r Web server Error Log file for more details.

As you can see I’ve annotated the code with the memory limit and the memory used when it dies - It doesn’t appear to be the memory limit which is causing the error.

What else do I need to change to make this work?

Also, this statement works quickly(last5)

This one fails (last 6)

After digging around a bit, I changed this line in archive.php

private $requestPrepend = ‘&trigger=archivephp’; -> private $requestPrepend = ‘&trigger=archive’;

No errors - what’s the difference between archivephp and archive?

what is in your web server error log files ?

The php error log just has the stock empty response error message from the archive script - there’s nothing from the server to log because the response was blank. There’s nothing from the server side logged because this must be a fatal error without a fatal handler to handle it.
The IIS 7.5 log just has a 500.0 error which doesn’t help us much.

Any tips on turning on more log events in Piwik? I tried a bunch of things yesterday and I never was able to get anything logged with the archivephp process. Thanks for your help.

I figured it out.
In IIS, the FastCGI Activity Timeout was set to 30 seconds. I changed it to 5 minutes and it worked!