Archiv.php fails to run


#1

Hello,

I tried to set up a web cron running archive.php on my virtual managed server. It fails to run with the following error:

Error in the last Piwik archive.php run:
archive.php expects the argument --url to be set to your Piwik URL, for example: --url=http://example.org/piwik/
–help for more information

The FAQ did not offer any suggestion on this and I could not find anything in the forum here.

Any help or suggestion is really appreciated.

Regards
Jimbo

: I run Piwik 2.1.0


#2

Just do what the error message tells you: Set the paramter “–url” to the location piwik is installed in.


#3

the archive.php uses a cURL to load your indexfile. so it needs a valid url to load. if you don’t have a virtual host you coul’d probably run it wit the url localhost.


#4

Thanks for the fast responses, feeling a little bit stupid, because I tried to add the parameter to the url first using ?url=… :S Now it works.