Apache Out of Memory After PHP Upgrade Ubuntu 14

I just tried to upgrade PHP from 5.5.9-lubuntu4.20 to the latest 7.1 PHP (using apt-get with ondrej PPA). The upgrade seems to work fine and I created a dummy page to display phpinfo() and it returned the new version of PHP. Then I try to hit the main piwik page and it doesn’t return the page. Instead in the apache2.4 error.log it displays “Out of Memory”. That is the only error. There is nothing in the piwik log either. I set the php memory_limit to 4G and then -1 and neither helped. Using free -m shows that there is at least 7G of memory free. There is no swap disk either.

I rolled back my snapshot after troubleshooting a bunch and then tried to upgrade again, but this time just going to 5.6. First off I removed the old php this time just to make sure it wasn’t a conflict. Then I used the same PPA as before and installed the latest 5.6 release. Confirmed upgrade with phpinfo() and then tried to hit the main piwik index.php page and same problem. Out of memory.

I rolled back at this point, but does anyone have any ideas why this would happen?