Anyone really Using this product?


(mrmark) #1

I have Piwik installed on three Wordpress sites and getting "no data"
I first installed the code as directed. Waited a day to see. No Data.
Tried to find help or somebody who know anything…

No Luck…

So I installed the WP Plugin hoping maybe someone on WP had any luck or that the plug in may do as advertised.
Nope. Doesn’t work either…

Day three and about to call it quits.

If there is any real person who has Piwik working on a wordpress install… Please let me know how you got it to work.
Or help me in finding out what I am doing wrong.

Thanks

Sorry for the sarcasm, but I am a bit frustrated and tired of wasting time trying to find an answer or directions.


(holch) #2

Come on, don’t exaggerate.

You have joined this forum today at 07:44 PM, have written exactly 2 posts. Non of which really is describing your problem. How are people supposed to help you? By guessing?

As this is not a forum of volunteers and not a paid support, we as users can’t really expect immediate response, can we?

I can understand that you might be frustrated after 3 days, but this is not the fault of this forum, is it?

I don’t know your problem and my installtion isn’t up to date, so I can’t really help you.

But you are getting a free product here and you can’t expect the rest of the world just to wait for being able to solve your problem.

Additionally, you should give people the change to help as well. Maybe posting a link to your website where PIWIK is installed might help.

And by the way, ever thought about an time issue? The main developers seem to be located in Europe. It is Friday night there, currently 10:35 pm (22:35). I think we should let them rest over the weekend, shouldn’t we?

I would also love to have immediate response whenever I post something, but you don’t even get that with paid support.

I am quite active in other projects (not here at Piwik) and to be honest, with your attitude i would really think about helping you out, even if I could.

In the other post the user had installed via the one click installation of Dreamhost. Is this your case as well or did you install yourself?


(mrmark) #3

Not asking for immediate reply (Thank You)

the website in question is thevegastourist.com

Currently I installed the Piwik Analytics plugin for WordPress.
and still getting nothing…

I would really like to know how “all these people” have it working right and what I am doing wrong.

Thank You In Advance for any help…


(holch) #4

Well, looking at your script and the one that is on the piwik website, I can see significant difference.

Not that this must be the problem, but it could.


(mrmark) #5

I just used the API to generate some fake visitors.
Nothing showed up. Nothing, nada.

The code you are seeing is the code from the WordPress Plugin

Just for sanity sake, I installed Piwik on another site using the code given to me at install (DreamHost One Click).
Used the API again to generate fake users and got nothing as well.

Any ideas on where to go from here??
Reinstall and try again?
Is it my install? My codes??

[quote=holch @ Apr 23 2010, 08:51 PM]Well, looking at your script and the one that is on the piwik website, I can see significant difference.

Not that this must be the problem, but it could.[/quote]


(holch) #6

[quote=mrmark @ Apr 23 2010, 09:03 PM]I just used the API to generate some fake visitors.
Nothing showed up. Nothing, nada.

The code you are seeing is the code from the WordPress Plugin

Just for sanity sake, I installed Piwik on another site using the code given to me at install (DreamHost One Click).
Used the API again to generate fake users and got nothing as well.

Any ideas on where to go from here??
Reinstall and try again?
Is it my install? My codes??[/quote]

As you are having also problems with the dreamhost one click install (as the other user), this might be a Dreamhost problem (not sure though).

Did you try to install it again? If it really is a one click installation, it shouldn’t be that much work.

I personally prefer to install my software myself. Maybe this is a solution for you. It is actually not complicated.

with the plugins I am usually a little conservative. especially if they interfere too much. One little change in the script in a new version and the plugin might be out dated. i don’t know if that is the case, just pointing out the different sources for trouble.


(mrmark) #7

I thank You Very Much for your time and help on this.
Looks like I need to do a Fresh install and do it myself.
Agree, its best to do it yourself when possible!
It just seemed that I got on the admin page and logged in that everything is good to go!

Oh well… We will see.

thanks .

Mark

[quote=holch @ Apr 23 2010, 10:09 PM]As you are having also problems with the dreamhost one click install (as the other user), this might be a Dreamhost problem (not sure though).

Did you try to install it again? If it really is a one click installation, it shouldn’t be that much work.

I personally prefer to install my software myself. Maybe this is a solution for you. It is actually not complicated.

with the plugins I am usually a little conservative. especially if they interfere too much. One little change in the script in a new version and the plugin might be out dated. i don’t know if that is the case, just pointing out the different sources for trouble.[/quote]


(vipsoft) #8

The tracking code on your web site points to: http ://www.mavrickmedia.com/visits/

Browse to http ://www.mavrickmedia.com/visits/piwik.js

It returns a 404 error. Obviously, your pages are unable to load Piwik’s JavaScript code.

No JavaScript … no tracking … no data.

Check your redirects / URL rewriting rules.


(mrmark) #9

First and foremost I would like to apologize for my behavior.
I cam eon a little rough and crabby. Too much time being sucked up on a simple project.
The need for answers and my own impatience, without regard to my fellow Piwik users.

I apologize.

My problem was answered in part from here and in part from a private email.
A complete fresh install and some database corrections I didn’t know I needed
and it is working like a charm.

Once I dig into it all and have a few days worth of data to work with,
I may need some guidance.

But three WordPress sites with code (no plugins) and all looking like
its suppose to (??) and I am a happy camper.

Thank You all for the help, the hand slapping and everything else…

I promise to behave from now on…

Mark

[quote=vipsoft @ Apr 23 2010, 11:04 PM]The tracking code on your web site points to: http ://www.mavrickmedia.com/visits/

Browse to http ://www.mavrickmedia.com/visits/piwik.js

It returns a 404 error. Obviously, your pages are unable to load Piwik’s JavaScript code.

No JavaScript … no tracking … no data.

Check your redirects / URL rewriting rules.[/quote]


(holch) #10

Any news on this?

Does it work now?