Any 1.8.3 problems? I have one - all visits not showing

Been using Piwik for years on many sites. Always ok. Piwik is an awesome open source software and is developed and supported by very talented people.

I did upgrade 1.8.1. to 1.8.2 but rolled back when there was that minor issue which was resolved quickly. But held off of going back to 1.8.2 for while. Piwik worked fine.

Then I did upgrade to 1.8.2

Then a day or so later i noticed the new 1.8.3 and did upgrade to 1.8.3

Somewhere in there I noticed that some visits weren’t being picked up (other people’s visits perhaps … but for sure my visits to sites … no i don’t block my ip or have cookies blocking my own visits). All sites have the piwik tracking code.

So, first, anyone else having similar issues?

If not, can Piwik people give me some hints ideas etc of what to try?

For now, I have looked at Visit log table and my visits aren’t there so it isn’t just presentation issue. I haven’t done total uninstall - reinstall yet. Want to see if there is something else to do first.


If youre using geoIP try disabling the plugin.

If not, is there any error in your weserver error logs?

Hi Matt,

I had recently installed GeoIP but hadn’t activated it yet. I have deleted its files from plugin folder just in case.

No obvious error log issues referring to Piwik. No php errors at all, no server log issues referencing my current IP when I go to my pages with Piwik code and these visits are not registered in Piwik.

Some visits are being registered by Piwik. But my counts are down across all sites so obvisouly some visits are not being registered by Piwik. I know my current test visits are not registienring.

I will try deleting all Piwik files and reinstalling 1.8.3 from scratch, and if that doesn’t change anything, then make new database too.

Ah, turns out it was Firefox setting “tell websites I do not want to be tracked” was checked.

This is newer feature in FF 14 and forgot I had it on.

Btw, if you use Firebug, you will not see piwik.php in the Net panel if you have this FF feature checked.

Problem solved.

Thanks Matt.