After Upgrading to the Latest Version


#1

Hi,

After upgrading to the latest version via softaculous. this is what piwik saysafter I log-in:
The string to escape is not a valid UTF-8 string in “@CoreHome/getDefaultIndexView.twig”.

Can someone please help me?
Thanks


#2

Hi,

I am from the Softaculous team.

Can you please open a support ticket with us we will check it for you.


(Matthieu Aubry) #3

We have a ticket for this problem : The string to escape is not a valid UTF-8 string in "@CoreHome/getDefaultIndexView.twig". · Issue #4410 · matomo-org/matomo · GitHub

can you paste the full error message?


#4

Thanks for the reply guys! Since I don’t have the time to troubleshoot it more. I just intsructed my VPS company to downgrade the php version into its original state before I upgraded into Piwik 2.0.1. Php 3.5.2 did create alot of errors for my sites specially the most important functions.

So I just abondoned the upgraded installation and started a new one with Piwik 1.12


#5

As for me, it could be fixed easily by setting:

[database]
charset = utf8

in config.ini.php…


(Matthieu Aubry) #6

@wolfang that’s really interesting, I didn’t expect this to fix the bug. Would you mind reverting the change to double check that the bug “returns” ? if the bug returns it would be great that you post a comment in this post with you solution: The string to escape is not a valid UTF-8 string in “@CoreHome/getDefaultIndexView.twig”. · Issue #4410 · matomo-org/matomo · GitHub


#7

@Matt I saw you already posted it; indeed, the problem returns.
Also, for me it only happens when I select the statistics for a website containing an umlaut (other websites work fine).
Also, the umlaut is not even rendered correctly in the menu top right…
I hope this helps, please tell me when further information is needed/useful.


#8

I’ve just installed the latest version and have hit the same problem aftering logging in, is there a solution yet?

charset = utf8 is already in my configuration file generated by Piwik.

Error Message: The string to escape is not a valid UTF-8 string in “@CoreHome/getDefaultIndexView.twig”.


(Matthieu Aubry) #9

Sorry there is no solution yet. Can you post your error on The string to escape is not a valid UTF-8 string in "@CoreHome/getDefaultIndexView.twig". · Issue #4410 · matomo-org/matomo · GitHub - the more people report the bug the more chance we have to be able to reproduce and fix it! thanks