After upgrade to 1.7.1 widgets of dashboard are loading and loading


#1

After upgrade from 1.6 to 1.7.1 a lot of my dashboard widgets (all default ones) try to load data without success (message: Loading widget, please wait… does not disapear) and I got the error message:

Oops… problem during the request, please try again.

I can add new widgets other than the default ones and they work (exept ‘Graph returing visits’) but Piwik does not save them in the dash and they are gone after sign out. “Reset dashboard” does not help either.

The other widgets outside the dashboard work as expected. In “Widgets” (Link in the header) the widgets which do not work in the dash work here (exept ‘Graph returing visits’). Weird.

I did all the actions written in faq entry 148 “After I updated Piwik, it stopped working (blank page, widgets not loading, error message, etc.).” but I have not had success. I deleted all files and reinstalled Piwik from a new and fresh download from scratch (but I reused the old database). That did not help either.

Any ideas from the experts? Thanks in advance.

Hani


(Matthieu Aubry) #2

#3

Thank you for prompt response. I did not find any noticable entries in the logs. I will try your other tipps when I have time later.

If I find the solution I will post it here.


#4

[ul]
[li] Have not found any specific errors in server logs.
[/li][li] I have just round about 10 visitors per day. So setup auto archiving of reports is IMHO not needed. Furthermore I have not access to cron-jobs.
[/li][li] I added the [General] section with the entry “session_save_handler = dbtable” in config.ini.php. It does not help.
[/li][/ul]

It must be a database problem. I installed PIWIK on a local webserver (XAMPP) and after importing the database in question I got the same result.

Regards, Hani


(Matthieu Aubry) #5

Can you email bug descrciption + this URL + piwik url login password to matt att piwik.org thanks


#6

Dear Matt,

with your and my hoster’s help I could solve the problem.

An old and in the meantime obsolete entry in my .htaccess file caused the problem. The entry should save me for a possible attack via ini-files of my cms. Now the leak is fixed.

The following entry caused the problem mentioned above.


#RewriteRule ^.*$ - [F,L]
#RewriteCond %{HTTP_REFERER} !^$
#RewriteCond %{HTTP_REFERER} !^http://(www\.)?my-domain\.tld(/.*)?$ [NC]
#RewriteRule \.(ini|INI|iNI|inI|Ini|INi|iNi)$ - [F] 

Thanks to Matt and to the support of all-inkl.com

Kind regards,

Hani

PS: Is it possible to mark this thread “solved”?