After disabling Browser Archiving, Segment reports now incomplete

Hello,
a couple of days ago, we disabled browser archiving in the UI as well as in the config.ini.php according to this guide.

; disable browser trigger archiving for all requests (even those with a segment)
browser_archiving_disabled_enforce = 1

The Custom segments only show data up to the point of the disabling. When the segments are saved again (which only admins are able to do now), the reports only show data beginning with the disabling.
The cron job was running the entire time.

Segment Original

Segment after Editing/ Saving

How can we get a report for the entire time?
Can only Admins create Segments from now on?

Best regards

Hi,

The “normal” way to disable browser archiving is via the Matomo settings.

This way normal reports are not archived on browser requests, but segments are still processed according to the settings of each segment (in the segment setting you can change if this segment should be pre-processed or processed on accessing it (via browser archiving)).

The setting you changed is a bit more extreme and disables all kinds of browser archiving on the Matomo instance. If you set your segment up to not be pre-processed, then it won’t be processed at all (as you can see).

  • By default, when you disable browser triggers for Matomo archiving, it does not completely disable the trigger of archiving as you might expect. Users browsing Matomo will still be able to trigger processing of archives in one particular case: when a Custom segment is used. To ensure that users of your Matomo will never trigger any data processing, in your config.ini.php file you must add the following setting below the [General] category:
; disable browser trigger archiving for all requests (even those with a segment)
browser_archiving_disabled_enforce = 1

How to Set up Auto-Archiving of Your Reports User Guide - Analytics Platform - Matomo

Update: I just noticed that I misread your question and you might already know that. I don’t know why the segments are shown only for part of the date range.

Hi Lukas,
yeah at first, we only used the normal setting, which worked fine except for segments, where performance was still dead slow. Therefore, we had to make some more drastic changes.
I don’t think normal users saw the option to select whether their segment should be pre-processed or not. Or is that a setting, that only admins can configure?

Regarding the splitted data, would it help to delete the old archived reports?
I stumbled across this setting (still new to Matomo)

Thanks Lukas, I appreciate your help.

Solution
These steps helped me getting back the full report.
I had to invalidate all segment reports for the date range up to my change, so that the reports could be re-processed.
."D:\PHP\php.exe" "C:\inetpub\wwwroot\console" core:invalidate-report-data --dates="2020-01-01,2020-04-28" --segment="[segmentDefinition]"
Afterwards I manually ran the archiving job again.
(Link)

1 Like