Admin Dashboard is empty

Hey, as you can see here:

The admin dashboard just shows completly white pages, except for the Menues.
I tried to deleted the tmp folders and changed the browser too…

Can you see any messages / errors in Firebug (or the Chrome developer console)?

You can start these debugging consoles by pressing F12 in your Browser, switching to the “Network” tab and then reloading the page.

Additionally, please check your webserver error logs for abnormalities.

Similar issue:

Have you checked this: How do I configure my server to let Piwik serve HTML files? - Analytics Platform - Piwik

On more thing I stumbled upon: If installed in a subdirectory make sure, that you dont inherit mod_rewrites from parent folders.

Having the same issue at the moment myself.

@stalefish and @PatrickBlub,

Can you check in the developer tools of your browser if there is an error in you console. Especially that some file couldn’t load.
Maybe also check in the network tab if any requests fail or return 4xx or 5xx codes?

Are you running any adblocker or something similar?

In addition, as @mediaproweb already mentioned, can you check for server errors in the php error log?

I am running an adblocker in Firefox, but I’ve tried this in Chrome/Edge which have non-adblocking.

I can get a screenshot in a moment, but as soon as it gets to the piwik/plugins/feedback or corehome/ angularjs directive files it reports 301 moved permanently errors then 403 Forbidden errors.

It is installed in a .com/analytics/piwik sub-directory.

I’m setting this up on the worse day possible as I’m ill so I’ve probably gone and missed something very stupid. Thanks.

Thanks, that seems to indicate (as in the other thread) that it is no blocking error.

That sounds much more interesting. To what URL does the 301 redirect (You should be able to see it if you click on the request in the Location: header.

Similar to here:

I had just find the location after I checked back here, that would have saved me some time, so thanks!

The request/GET URL is : “”

The Response location, copied from the section you circled is also "

and then the 403 refusal (as a new user I can only post one image per post, so apolgies for the post spam)


Your server seems to remove the .html from the end of the URL.

Is it possible that you are using a CMS in the root directory which has a .htaccess that includes this redirect.

And as Piwik is in a subfolder it inherits this settings which break it.

1 Like

… Damn it.

That’s on me, I have that in the .htaccess file, which I even checked when I saw the 301’s, saw it didn’t affect the php and I didn’t even think of the .html and it’s implications on the piwik dashboard.

I’ll have to route out a fix for that.

Hah. Very sorry about that, knew it would be something blindingly obvious I missed. Not on the ball today.

Thanks a lot though.

@PatrickBlub and @Sanna,

does something like this also solve the issue for you?

Nein leider nicht. Habe dir die Antwort im meinem Post gegeben:

I’m experiencing the same issue as PatrickBlub. Here’s the error that shows up in the console: Uncaught Error: [$injector:modulerr] AngularJS