Action 'index' not found in the module 'CustomVariables'


#1

After the last updates i get the error below when I click on Custom Variables:

Action ‘index’ not found in the module ‘CustomVariables’.

Piwik is updated to the latest version, still getting this error.

Any idea on how to fix this?


(Matthieu Aubry) #2

please try latest Piwik beta: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo
where this bug should be fixed


#3

I have the same issue, updated to the latest beta version but the same error appears.


#4

I managed to solve the problem

  1. Updated to the latest version 2.9.1
  2. I replaced index with getCustomVariables within CustomVariables/Menu.php (more info here )
  3. Deleted the tmp/cache folder
  4. Disabled and re-enabled the Custom Variables plugin.

The error has gone away, seems to be working.


(ITfee) #5

Same bug here, the temporary fix from sinaps worked for me. Thanks for that!