Access forbidden error fresh install of Matomo/piwik


#1

During installation I encounter an “access forbidden!” error. Thanks for reading and for suggestions!
Details:

I wish to install and use Matomo/Piwik on a local server running OpenSUSE Leap 15 that has PHP version 7.2.5 and MySQL version 10.2.15-MariaDB. Apache2 is installed and works fine because my website, www.[host].edu loads fine over the web.

I followed the steps on the Requirements page, and the MySQL database creation process was fine. The only issue was that php.cli didn’t exist in the repository so I was unable to install that. All other pieces were in the repository and installed without error.

I then followed the steps on the Getting Started page, and the ‘wget’ command worked great. Using SSH I can see that that the piwik.zip, “How to …” files and the “piwik” directory are in /srv/www/htdocs/analytics/ .

I run into trouble when navigating my web browser to www.[host]/edu/analytics . Instead of returning the beautiful Installation screen, it returns this:


Access forbidden!

You don’t have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.

Error 403

[host].edu
Apache

It seems like a permission issue, and so I tried a large number of permutations of chmod -R, chgrp -R, and chown -R commands. But nothing seemed to resolve the issue. I also tried navigating the browser to www.[host].edu/analytics/piwik but again same “access forbidden!” error appears. I’ve also tried restarting apache2 several times after changing permissions but this did not help. Thank you.