A fatal error occurred error

Please contact the system administrator, or login to Matomo to learn more.

If you are Super User, but cannot login because of this error, you can still troubleshoot further. Follow these steps:

  1. open the config/config.ini.php file and look for the salt value under [General] .
  2. edit this current URL you are viewing and add the following text (replacing salt_value_from_config by the salt value from the config file):


There are no operations. It suddenly became like this. It has been running for more than one year. Statistics show that there are more than 20 websites

Hi @leibei
Is there any automatic Update on your Matomo?
Can you see errors in the Matomo error log file?

I didn’t update automatically. I just received an update reminder, so I updated it. Then I made this error a few days later. How to solve this problem? I don’t want to update the reminder, because I use many websites, and stability is the first. Thank you.Thank you.

Can you see (other) errors in the Matomo error log file?

Matomo error log file
Where can I see this file. I have VPS permission Thank you

Check on your configuration files ("config/config.ini.php" and / or "config/common.config.ini.php" and or "config/global.config.ini.php") under the [log] section: logger_file_path.
Or else the log file may be located at: tmp/logs/matomo.log

Do not see tmp/logs/matomo.log

They only show up there if you enable logging in Matomo:

But a fatal error should also show up in the general PHP error log provided by your web hosting company.

How to solve this problem. Or restore to the old version.

That depends on the error that occurred. And that you can find in the error logs provided by your web host