2.2.2 generated (weekly) report AND manual report do not work any more


#1

After upgrading 2days ago I realized that the expected weeky report didn’t arrive. Checked the settings and tried to send me a manual report or generate a download. Didn’t work:

This is the message I got (above the list with the reports):

API returned an error: Trying to add two strings values in DataTable\Row::sumRowArray: ‘0%’ + ‘100%’ at Row.php:581

Any Idea?

Thanks.


#2

Theres a whole thread related to this.

Just curious what server environement and php version are you running?


#3

Forgot link

http://forum.piwik.org/read.php?2,114885,115198#msg-115198


(Matthieu Aubry) #4

This is a known bug, we are right now working on a solution: Trying to add two strings values in DataTable\Row::sumRowArray · Issue #4706 · matomo-org/matomo · GitHub


#5

Thank you for the link to the other thread.
I forgot to attach this information:
PHP version is 5.3.28
Apache/2.2.26 (Unix)
I hope this can help. If you need the full phpinfo, I can PM that.
Thanks.


#6

I’m getting this error as well with 2.2.2. Let me know if you need my specific server details. I’m mostly commenting here so that I can have replies to this thread emailed to me when this issue is resolved.


#7

Add your specs as user above as it could show a trend towards a config type that might help diagnose. Can you upgrade your php if its below 5.3.3?


(Matthieu Aubry) #8

Hello, This bug has been fixed in latest beta version: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo


#9

Matt, the beta (2.2.3-b4) fixes it for me. Thanks!


#10

Thanks! Beta 2.2.3-b6 fixed it also for me.