1.12-b6: Undefined index: nb_visits_22 when generating eMail report

I have updated from 1.11.1 to the Git tag 1.12-b6. When I download an eMail report I get following error message:


Notice: Undefined index: nb_visits_22 in /srv/.../piwik_git/plugins/ImageGraph/API.php on line 401
Backtrace -->
#0 Piwik_ErrorHandler(...) called at [/srv/.../piwik_git/plugins/ImageGraph/API.php:401]
#1 Piwik_ImageGraph_API->get(...) called at [:]
#2 call_user_func_array(...) called at [/srv/.../piwik_git/core/API/Proxy.php:187]
#3 Piwik_API_Proxy->call(...) called at [/srv/.../piwik_git/core/API/Request.php:121]
#4 Piwik_API_Request->process(...) called at [/srv/.../piwik_git/core/ReportRenderer.php:237]
#5 Piwik_ReportRenderer::getStaticGraph(...) called at [/srv/.../piwik_git/core/ReportRenderer/Html.php:141]
#6 Piwik_ReportRenderer_Html->renderReport(...) called at [:]
#7 array_walk(...) called at [/srv/.../piwik_git/plugins/PDFReports/API.php:418]
#8 Piwik_PDFReports_API->generateReport(...) called at [:]
#9 call_user_func_array(...) called at [/srv/.../piwik_git/core/API/Proxy.php:187]
#10 Piwik_API_Proxy->call(...) called at [/srv/.../piwik_git/core/API/Request.php:121]
#11 Piwik_API_Request->process(...) called at [/srv/.../piwik_git/plugins/API/Controller.php:25]
#12 Piwik_API_Controller->index(...) called at [:]
#13 call_user_func_array(...) called at [/srv/.../piwik_git/core/FrontController.php:125]
#14 Piwik_FrontController->dispatch(...) called at [/srv/.../piwik_git/index.php:47]

I just tested and it works fine on the demo. can you try to builda new report ? or replicate in a new piwik install? in which case I will definitely fix it of course!

I did a new install and just loaded some traffic from the visitor generator.

I can reproduce it, but it seems to be related to the display options of the report. When I select to show table and graphs and select “Show Historical Graphs for the top 5 values” I get this error. When I remove the checkbox of the historical values there is no error.
The same behavior I could also confirm on my old installation.

Thanks. I also can reproduce the issue on the demo. We will fix this issue before final 1.12!